The Will Will Web

記載著 Will 在網路世界的學習心得與技術分享

ASP.NET 3.5 要如何安裝在 IIS 5.0/6.0 中

這幾天在玩 .Net 3.5,發現了一個疑問,就是在 IIS 裡面為什麼看不到 ASP.NET 3.5 的選項?!且以前在 .NET 2.0 的時候有個 aspnet_regiis.exe 的執行檔在 .NET 3.5 也看不到!!

後來我才搞懂,原來 ASP.NET 3.5 只是使用 .Net Framework 3.5 的組件(assembly)而已!整個核心的架構還是建立在 .NET 2.0 之上,.NET Framework 的 API 都沒變,只是到了 .NET 3.5 很多 assembly 都重新寫過了,且執行的速度也比 .NET 2.0 的組件還快。

如果你用 Visual Studio 2008 開一個網站專案,你開啟 web.config 會發現在 <assemblies> 區段中出現了一堆 assembly 的定義,其版本都是 3.5.0.0

  <compilation debug="true">
   <assemblies>
    <add assembly="System.Core, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    <add assembly="System.Data.DataSetExtensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
    <add assembly="System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
    <add assembly="System.Xml.Linq, Version=3.5.0.0, Culture=neutral, PublicKeyToken=B77A5C561934E089"/>
   </assemblies>
  </compilation>

所以 ASP.NET 3.5 的程式要安裝在 IIS 上不需要特別指定 ASP.NET 3.5 的版本,繼續沿用 ASP.NET 2.0 的版本即可,但作業系統本身必須要先安裝 .Net Framework 3.5 runtime 就是了!
如果你要知道你的程式是用什麼 .NET 版本的話,可以用以下程式碼取得:
[code:html]
<%= System.Environment.Version  %>
[/code]